
 Habitat Protection Representation Tutorial 

Version 2.0 (QGIS) 

 

Background: (1) Coastal and marine habitats are vibrant ecologically and provide vital resources 

that sustain human populations. Numerous threats by climate change and human activities reduce 

the ability of the habitats to support biodiversity, ecosystem functions, and ecosystem services. 

Protected areas can allow those habitats to be more resilient and maintain key capacities, by saving 

species populations and crucial ecological interactions. Recently, a push globally for increased 

protection has occurred. Many questions remain on what and how much is protected. As a 

consequence, it is important to know what and where habitats have been protected currently. 

Purpose: Through this lesson, participants get an introduction to using fundamental and regularly 

used geospatial tools to analyze conservation situations. In particular, participants will integrate Allen 

Coral Atlas data with timely protection data in order to address conservation targets. By the end of 

this task, you will be able to calculate the percentage of the protected areas and determine if the 

protection goals are met. 

Objectives: (1) Learn about the Allen Coral Atlas benthic data, (2) Become familiarized with basic 

GIS analysis tools, (3) Understand how different freely available data sources can be combined to 

investigate conservation questions 

Technical requirements: Computer, GIS Software (QGIS), Internet 

Target audience: Beginner / Moderate GIS user 

Expected time for completion: 2 - 4 hours 

 

Before Beginning: 

● If you do not have a GIS software already pre-installed on your machine, QGIS is a free and 

open-source software that can be translated into nearly 88 languages (how to change the 

language). 

○ ***Recommendation: Download the long-term release as it will be more stable. 

● Within the "Level 2 Habitat Protection Tutorial" folder, are the following: 

○ A copy of this tutorial 

○ A folder called "gis_data"  

■ Geodatabase (tonga_habitat.gdb): contains required files for this tutorial (1) 

benthic data for central Tonga, (2) geomorphic data for central Tonga, and 

(3) Tonga protected area data 

■ Four empty folders: (1) tonga_admin, (2) tonga_analysis, (3) 

tonga_ecological, (4) tonga_protection 

● ***Note: these will be where downloaded and produced folders will 

be saved 

○ Software: QGIS 3.10 (June 2020 long-term stable release) for Macintosh and 

Windows (32- and 64-bit) computers 

● The hyperlinks in the steps direct you to a page with data or more information about the 

tool or process used. 

https://qgis.org/en/site/index.html
https://www.transifex.com/qgis/QGIS/
https://docs.qgis.org/3.10/en/docs/user_manual/introduction/qgis_configuration.html#general-settings
https://docs.qgis.org/3.10/en/docs/user_manual/introduction/qgis_configuration.html#general-settings
https://qgis.org/en/site/forusers/download.html
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● QGIS defaults to creating a temporary layer when a tool is run. 

○ ***Recommendation: Click the "…" (ellipsis) next to the field and select "Save to file" 

for any step that a file needs to be saved 

 

Considerations: 

● The Allen Coral Atlas provided the benthic and geomorphic data. Tonga protected areas 

were derived from the March 2020 update for the World Database on Protected Areas 

(WDPA) through Protected Planet 

● The Allen Coral Atlas benthic and geomorphic data when downloaded are in a geographic 

coordinate system: WGS84 

● For area calculations, the data should be in a projected coordinate system (e.g., Mollweide or 

UTM) 

○ Save data in another coordinate system in QGIS 

● The benthic and geomorphic data are being provided to you already in a projected 

coordinate system (i.e., Mollweide). This is due to the time required to project the Allen 

Coral Atlas benthic data to a new projection (~20 minutes). 

○ ***WARNING: The area of interest benthic and geomorphic data already have their 

areas calculated, but they are in square meters 

○ ***WARNING: It is not recommended to calculate geometry (which will be 

discussed further in the tutorial) in the hectares unit of measure for at least the 

benthic data, as it will take approximately 2 hours. An alternative is to use the "Field 

Calculator" and convert from square meters to hectares (square meters / 10000 = 

hectares) 

 

Additional comments: 

● If desired to recreate the central Tongan dataset or repeat for another area, the process is as 

follows: 

○ Download the EEZ layer for the area of interest (Maritime Boundaries v11) 

○ Load the data in GIS software 

○ ***Note: If multiple EEZs exist for the area of interest, run the required tool to make 

the single polygon feature into unique polygon features 

■ Multipart to singleparts in QGIS 

○ Select the area of interest 

○ Export selected as new shapefile 

○ Load the benthic and geomorphic data 

■ ***Note: If the benthic and geomorphic data have not already been projected 

to a projected coordinate system do so 

■ ***Note: If an area field does not exist for the benthic or geomorphic data, it 

should be added (e.g., Add Geometry Attributes… in QGIS); area fields 

should be in matching units (e.g., hectares, square kilometers, etc.) 

○ Clip the benthic and geomorphic data to the area of interest 

https://allencoralatlas.org/
https://www.protectedplanet.net/
https://docs.qgis.org/3.10/en/docs/training_manual/vector_analysis/reproject_transform.html#moderate-fa-saving-a-dataset-to-another-crs
http://www.marineregions.org/downloads.php
https://docs.qgis.org/3.10/en/docs/user_manual/processing_algs/qgis/vectorgeometry.html?highlight=multipart%20split#multipart-to-singleparts
https://docs.qgis.org/testing/en/docs/user_manual/processing_algs/qgis/vectorgeometry.html#add-geometry-attributes
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■ Vector geoprocessing > Clip in QGIS 

 

Phase 1: Obtaining data 

1. Tonga Land Boundary 

a. In the drop-down menu, select Tonga from the Global Database on Administrative 

Areas (GADM) 

 

 
2. Click on the shapefile file format hyperlink and wait for the download. 

a. ***Note: Can read more about the available file formats for downloading here. 

3. Unzip the folder from the download location 

a. Windows users: default option will be using the "Extract All…" and then following 

the directions 

i. ***Recommendation: Download and install 7-Zip. It is free and provides greater 

options and faster compression and extractions. 

b. Rename data to a more identifiable name (e.g., tonga_land_wgs84 → 

location_description_coordinate system) 

i. Separate between the level 0 data and level 1 data 

ii. ***Note: Level 0 data are the data that will be used in the analysis 

iii. ***Note: Level 0 data are a single feature for the country, while Level 1 have 

five features for the five island groups (ʻEua, Haʻapai, Niuas, Tongatapu, and 

Vavaʻu) 

https://docs.qgis.org/3.10/en/docs/user_manual/processing_algs/qgis/vectoroverlay.html#clip
https://gadm.org/download_country_v3.html
https://gadm.org/download_country_v3.html
https://gadm.org/formats.html
https://www.7-zip.org/
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***Note: 7-Zip is a free download for quick data 
extraction 

This is the Windows, default option 

(1) Highlight all files with the 
name gadm36_TON_0 
(2) Right-click 
(3) Select the rename option 
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4. Move the tonga_land_wgs84 files to the tonga_admin (i.e., administrative data for Tonga) 

folder in the gis folder 

a. ***Note: Make sure to copy all the associated files for the Tonga land layer (.cpg, 

.dbf, .prj, .shp., .shx) 

b. ***Note: Can move the other data as well, but they are not required for this tutorial. 

When indicated, type in "tonga_land_wgs84" 
 
***Note: Make sure to only rename everything before the 
file type (.filetype). For example, as seen in the first file its 
new name is added, but the .cpg remains. This will 
maintain all the filetypes 

 

As seen here, all files previously highlighted will have 
the name populated with the name, but maintain any 
part left unedited (i.e., the filetype) 
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5. Maritime 12 nautical mile boundary 

a. Under the Maritime Boundaries v11 section, select the shapefile option for the 12 

nautical miles dataset 

http://www.marineregions.org/downloads.php
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6. In the pop-up window, enter all the required information. 

a. Name 

b. Organization 

c. E-mail 

d. Country 

e. Reason for using these data 

f. Mark the "Agree to the disclaimer" 

g. Click "Download" 

 

 
 

7. Unzip the folder from the download location and move to the tonga_admin folder. 

a. ***Recommendation: rename the data to a more identifiable name (e.g., 

global_12nm_v11_wgs84) 

 

Phase 2: Checking data 

8. Open QGIS 

9. Add the GIS data (12nm, landmass, benthic, geomorphic, and protected area) 

a. The 12nm and land boundary data (level 0) are from the tonga_admin folder 

i. ***Note: Do not use the island group data if those data are in tonga_admin 

 

Download will automatically start 
after clicking "Download" 

Make sure to check the "Agree" box 
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b. The benthic and protected area are in the provided in the tonga_habitat geodatabase 

c. Multiple ways to add data to QGIS 

i. Layer > Add Layer > Add Vector Layer… 

ii. Click the "Add Vector Layer" symbol in the Manage Layers Toolbar 

iii. Add data through the browser panel 

iv. (4) Ctrl + Shift + V (Windows) / cmd + shift + V (Mac) [further QGIS 

guidance] 

 

 
 

v. QGIS has a unique way for adding the data from the geodatabase 

1. Same steps for adding the administrative data, but instead of the 

source type being "File" (which is the default), select "Directory" 

2. Type = OpenFileGDB 

3. After hitting "Add", make sure all the layers have been added 

vi. ***Note: If using options 1, 2 or 4, then only select the *.shp file for the 

desired layer (e.g., tonga_land_wgs84.shp) 

 

1 
2 

3 

Method 3 options: 
1. Double click layer 
2. Drag to Layers Panel 
3. Drag to canvas 
4. Right-click and select option to 

add layer to canvas 

If this toolbar is not 
appearing (and it may be 
elsewhere when QGIS is 
opened), follow these 
steps: 

• View > Toolbars (4th 
from bottom) > 
Attributes toolbar 

• Check the Attributes 
toolbar 

https://docs.qgis.org/3.10/en/docs/user_manual/managing_data_source/opening_data.html#loading-a-layer-from-a-file
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***Recommendation: Right now the plot view is at the globe level. This makes it difficult to see the 

data specific to Tonga. A quick change for the extent to match that of the Tonga central region is to 

right-click tonga_land_wgs84 and select the "Zoom to Layer." Now the data view should be 

zoomed and centered around Tonga. 

 

 
 

***Explore: Turn on and off the layers in the Layers panel by marking and unmarking the box next 

to the layer name in the Layer panel. 

 

 

After clicking "Add" this box 
will appear 

Select the 

 

***Note: 
Can add 
data 
through the 
browser 

Zoomed-in view 

Original view 
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Check-in 1: Are there any layers that do not appear even when they are turned on? If so, which 

ones? 

 

10. Examine properties of the data 

a. Coordinate system 

i. Double left-click on the layer (or right-click and select "Properties"), navigate 

to "Source" and check the Coordinate Reference System 

 

 
 

Check-in 2: How many different coordinate systems are your data in? 

A. 1 

B. 2 

C. 4 

D. 5 

 

Phase 3: Preparing data 

11. Export the geodatabase data as their own layers to allow for data use (***Note: repeat for 

each layer) 

a. tonga_central_benthic_moll and tonga_central_geomorphic_moll should be 

exported to the tonga_ecological data 

b. tonga_wdpa_march2020 data should be located to the tonga_protection folder  

c. Right-click on feature, select "Export" > "Save Feature As..." 

i. Browse to the tonga_ecological GIS folder by clicking on the ellipses (...) to 

the right for "File name" 
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ii. Can maintain the same name (e.g., tonga_central_benthic_moll) or change it 

to something more preferred 

iii. Maintain the same coordinate system (CRS) 

iv. Click "OK" to save the data as new layer 

 

 
 

12. Match all the data into the same coordinate system 

a. Change the projection coordinate systems for the 12 nautical mile data, land data, 

and the WDPA data 

b. Save data in another coordinate system 

i. Right-click on feature, select "Export" > "Save Feature As..." 

1. Format = ESRI Shapefile 

2. Filename → should designate that it is in the Mollweide coordinate 

system (e.g., tonga_land_moll) 

3. CRS = EPSG:54009 - World_Mollweide 

a. ***Note: If the geomorphic and benthic data have already 

been added, then the Mollweide coordinate should already 

appear (the program is populating coordinate systems that the 

other data are in) 

b. ***Note: If the coordinate system does not appear, select the 

globe icon next to the CRS field and a selector pop-up should 

appear. Type in Mollweide or 54009 in the filter and select 

the World_Mollweide EPSG:54009. Double click or hit okay. 

1 

2 

3 

4 

Format →  Shapefile 
Folder → 
tonga_ecological 
 

+ 
 
Filename (e.g., 
tonga_central_geomor
phic_moll) 

Make sure that data are still in Mollwiede system 

https://docs.qgis.org/3.10/en/docs/training_manual/vector_analysis/reproject_transform.html#moderate-fa-saving-a-dataset-to-another-crs
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i. Alternative is to navigate through the projected 

coordinate systems [Projected Coordinate System > 

Mollweide > World_Mollweide] 

 

 
 

13. If the projected data in Mollweide have not been added to the layers panel, add them 

a. ***Recommendation: to clean up the panel and reduce error, remove the data that were 

in WGS84 

i. This is done by right-clicking the layer and selecting "Remove Layer... " 

b. Zoom to a data layer in the Mollweide coordinate system 

 

***Note: Repeat the process until all the layers are in Mollweide coordinate system. 

 

***Explore: Turn on and off all the Mollweide layers to see if all the layers appear in the data 

window. 

 

1 

1 2 

3 

4 5 

6 

7 

8 

Format = ESRI Shapefile 

Filename 
should 
designate 
that the 
layer is in 
Mollweide 
(e.g., 
filename_
moll) 

Clicking this icon will open 
the "Coordinate Reference 
System Selector" window 

***Recommendation: fastest way is to 
type 54009 in the search 

Select the 
"World_Mollweide
" reference system 



Habitat Protection Representation Tutorial 

Page 13 of 31 Allen Coral Atlas 

 
 

Check-in 3: How many layers have their coordinate reference system in Mollweide? 

 

14. Examine the 12 nautical boundary data to see which territories are included in the data  

a. Check the attribute table to notice that the data are global 

i. Right-click on the global_12nm_v11_moll data layer and select "Open 

Attribute Table" 

b. Alphabetize the Territory1 field to find Tonga 

i. Click on the Territory1 field till the small arrow to the right is pointing 

upwards 

1. ***Alternative: Right-click on field and select sort and click the option 

to sort ascending. 
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Check-in 4: How many territories are included in the data? What is the ISO code for Tonga? 

 

15. Subset the nautical boundary to only have Tonga's 12nm data. 

a. Open properties > Source > click "Query Builder" 

i. Double click the "Territory1" to have it added to the expression box 

ii. Click the equals (=) operator 

iii. Relight the Territory1 field and select "All" to populate the values 

iv. Type in Tonga in the "Search" bar (alternatively could scroll till Tonga) 

v. Double click on Tonga to add it to the expression bar 

vi. ***Note: the expression box should appear as "TERRITORY1" = 'Tonga' 

(alternatively, can also type that expression directly into the expression box) 

vii. Click "Test" to check that the expression works 

viii. Click "OK" 

ix. Click "Apply" 

 

 

Black arrow should 

https://docs.qgis.org/3.10/en/docs/user_manual/working_with_vector/vector_properties.html#query-builder
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Check-in 5: How many territories are shown in the attribute table? 

 

16. Export the Tonga 12nm boundary layer as its own data source to the tonga_admin folder 

a. Right-click on feature, select "Export" > "Save Feature As..." 

b. Browse to the Tonga_admin folder 

c. Rename to designate that these data are for Tonga (e.g., tonga_12nm_v11_moll) 

d. Save 

17. Add newly created data to canvas if they were not already added and remove the global 

12nm boundary data 

18. Zoom to the entire Tonga 12nm data 

 

Check-in 6: How many polygons appear to comprise the Tongan 12nm boundary? 

 

19. May look like there are multiple polygons, but the data are a single feature (see attribute 

table). To get each polygon to be its own feature, the data need to be split 

a. ***Note: This will have the data create unique features for every separated polygon 

b. Multipart to Singleparts (Vector > Geometry Tools) 

i. Click "Vector" in the ribbon 

ii. Navigate to Geometry tools and select "Multipart to Singleparts") 

iii. Input layer = Tonga 12nm data (in Mollweide) 

iv. Click the "..." (ellipses) to select the output folder (tonga_admin) and the 

filename (e.g., tonga_12nm_v11_single_moll) 

 The expression will be 
populated here after 9 

1 

2 

3 

4 

5 

This will update as 3, 4, and 7 
are completed 

6 

8 9 

10 11 

Double click to 
have it added to 
the expression box 

Highlight 
TERRITORY
1 before 
clicking "All" 

Values will 
dynamically change 
as more characters 
are added 

7 

https://docs.qgis.org/3.10/en/docs/user_manual/processing_algs/qgis/vectorgeometry.html#multipart-to-singleparts
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v. Keep the default filetype as shapefile (.SHP) 

vi. Click "Save" 

vii. Click "Run" 

c. If the data were not added to the "Layers" panel, add them 

 

 
 

Check-in 7: How many features are in the singlepart version of the Tonga 12nm boundary layer? 

How does that number compare to the number for the last check-in? 

 

20. Boundaries around islands are for all islands, but benthic and geomorphic data are only in 

the centralized system. To obtain only the 12nm boundaries that have benthic and 

geomorphic data, run a selection by location. 

a. Select by Location (Vector > Research Tools) 

i. Select by Location (Process 1) 

1. Enter "Vector" in ribbon, navigate to "Research Tools" and open 

"Select by Location" 

2. Select features: Tonga 12 nm single features 

3. Geometric predicate: intersects 

4. Comparing features: Tonga geomorphic data 

5. Modify: creating a new selection 

6. Click "Run" 

b. ***Alternative: Extract by Location, which will select and save as new layer 

i. Extract by Location (Process 2) 

1. Open "Processing Toolbox" from within the "Processing" option in 

the ribbon 

1 

2 

3 

4 
5 6 

https://docs.qgis.org/3.10/en/docs/user_manual/processing_algs/qgis/vectorselection.html#select-by-location
https://docs.qgis.org/3.10/en/docs/user_manual/processing_algs/qgis/vectorselection.html#extract-by-location
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2. Search "Extract by Location" or find it under "Vector Selection" 

3. Extract features from: Tonga 12nm single features 

4. Geometric predicate: contain 

5. Comparing features: Tonga geomorphic data 

6. Extracted location: output folder (tonga_admin) and filename (e.g., 

tonga_12nm_v11_moll_single_central) 

7. Click "Run" 

 

Check-in 8: What happened after you clicked "Run"? 

 

 
 

c. To alleviate this issue, run a buffer on the benthic and geomorphic data 

i. A buffer extends the edges of the data by the inputted distance (e.g., a 10km 

buffer around a point will create a circle with a radius of 10km) 

ii. The geometry will be fixed even with a buffer of 0 (i.e., 0 meters) 

d. Open Buffer (Vector > Geoprocessing Tools) 

i. Input layer: tonga_central_benthic_moll / tonga_central_geomorphic_moll 

ii. Distance: 0 

iii. Units: meters 

iv. Buffered: navigate to tonga_ecological and rename file to reflect the new 

name (e.g., tonga_central_benthic_buffer_moll) 

v. Click "Run" 

e. Add new layers if they were not automatically added to the layer panel 

Process 2 Process 1 

Can save the results as a new layer (e.g., 
tonga_12nm_v11_moll_single_central) 

2a 

2b 

2c 

2d 

2e 

2f 

1a 

1b 

1c 
1d 

1e 

https://docs.qgis.org/3.10/en/docs/user_manual/processing_algs/qgis/vectorgeometry.html#buffer
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f. Use these new layers in the rerunning of "Select by Location" or "Extract by 

Location" 

i. ***Note: If still getting an error with invalid geometry, use the "Check 

Validity" tool in the Processing Toolbox to generate the errors 

ii. Open the Error Output and zoom to feature to see where issue is happening 

iii. Rerun buffer and change the number of segments (start with 1) if error 

persists 

 

 
 

21. Export selected features as new layer (if that has not already occurred) 

a. Save with name that indicates these data are for the central region (e.g., 

tonga_12nm_v11_single_central_moll) 

 

Check-in 9: What percent of the 12nm boundary features have benthic data? 

 

22. Obtain only protected areas that are coastal and marine using the "Query Builder" function 

again, but on the tonga_wdpa_march2020_moll layer this time 

a. ***Note: reference the previous use of "Query Builder" to remember how to access 

the functionality 

b. In this case, the query should select all the coastal and marine protected areas using 

the data's "Marine" field  

i. 1 = coastal area 

ii. 2 = fully marine 

c. Perhaps an easier way to do it, however, is to select everything that is not those. 

i. 0 = land 
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d. The "<>" means "not equal to", so "Marine" <> '0' is the equivalent of saying: 

"select all of the WDPA data that are not equal to 0". 

i. ***Recommendation: If worried about creating errors, pick the field name and 

operator from the options rather than typing it, and use the ‘Get Unique 

Values’ button to select 0. 

ii. ***Recommendation: For what each SQL operator does 

iii. ***Alternative: In QGIS, in place of clicking "<" and then ">", the "!=" will 

do the same. "!=" also means "not equal to" 

e. ***Note: further detail in Table 3.1 (page 16) in WDPA manual 

23. Export the WDPA data as a new layer (e.g., tonga_WDPA_marine_moll) in the protection 

folder 

24. Select by location the WDPA data that overlap the Tonga central region to generate a new 

layer (i.e., where the benthic data are located within). 

 

 
 

Check-in 10: How many coastal and marine protected areas are in the central region for Tonga? 

 

Phase 3: Creating data 

***Note: For simplicity the marine and coastal protected areas (layer with 38 features) will be 

referenced as just marine WDPA in the steps. 

 

25. Extract the benthic data located in coastal/marine protected areas 

a. Clip (Vector > Geoprocessing Tools) 

i. Input layer: buffered central Tonga benthic data 

ii. Overlay layer: marine WDPA data for the central Tongan region 

0 = terrestrial 
1 = coast 
2 = marine 

Alternative is "MARINE" <> '0' 

 

https://www.w3schools.com/sql/sql_operators.asp
https://www.protectedplanet.net/system/comfy/cms/files/files/000/000/203/original/WDPA_WDOECM_Manual_1_6.pdf
https://docs.qgis.org/3.10/en/docs/user_manual/processing_algs/qgis/vectoroverlay.html#clip
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iii. Save in the ecological folder with a name detailing the data (e.g., 

tonga_central_benthic_wdpa_moll) 

 

 
 

26. Run a spatial join to get which protected area is associated with each unique benthic class 

area 

a. Join attributes by location (Vector > Data Management Tools) 

i. Input layer: the clipped benthic data 

ii. Join layer: marine WDPA data for the central Tongan region 

iii. Geometric predicate: intersects 

iv. Join type: one-to-many 

v. Save in the ecological folder with a clear name (e.g., 

tonga_benthic_wdpa_join_moll) 

 

https://docs.qgis.org/3.10/en/docs/user_manual/processing_algs/qgis/vectorgeneral.html#join-attributes-by-location
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27. Consolidating the data to have the benthic categories each protected area will rely on the 

dissolve tool 

a. Dissolve (Vector > Geoprocessing Tools) 

i. Input layer: joined benthic and protected area data for the central Tonga 

region 

ii. Dissolve fields: Dissolve the data using the benthic class [Benth_Comp] / 

and protected area name [NAME] 

1. ***Note: For geomorphic data, the field will be [Geo_Zone] 

iii. Save the data in the ecological folder with a name that is clear (e.g., 

tonga_central_benthic_wdpa_join_dissolve_multi_moll) 

Mark "intersects" 
 
Select the (one-to-
many) option 

https://docs.qgis.org/3.10/en/docs/user_manual/processing_algs/gdal/vectorgeoprocessing.html#dissolve
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28. ***Explore: Only if the resulting layer has 258 features. There should be 251, so what are the 

extra 7? 

a. Sort alphabetical down (A-Z) using the NAME field 

b. Click the editing icon (Pencil) 

c. Select the rows that lack any data for the WDPA information 

d. Click the delete icon (red trash can) for all the selected features 

e. Click the save icon (floppy disk) to save edits 

f. Click the editing icon to close the editing session 
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29. Calculate the cover extent of each protected area’s benthic category in hectares 

a. ***Note: Areas should be no larger than 795, if the areas are in the tens of thousands 

or greater, then the area needs to be recalculated. 

b. ***Recommendation: Will want to check the "Units of area measurement" before doing 

the next steps 

i. Project > Properties (Ctrl+Shift+P) 

ii. General > Measurements 

iii. Units of area measurement = Hectares 

1. ***Note: If unit of measurement is square meters change to hectares 

 

 
 

 

https://docs.qgis.org/3.10/en/docs/user_manual/introduction/qgis_configuration.html#general-properties
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c. Calculate area in new field 

i. Open attribute table 

ii. Click the icon for field calculator (or Ctrl+I) 

iii. Mark the "Create a new field" option 

iv. Output field name = Area 

v. Output field type = Decimal number (real) 

vi. Output field length = 10 

vii. Precision = 3 

viii. Under Geometry select $area 

1. Can also search for area 

2. Or type "$area" in the expression box 

 

 
 

***Note: Could also recalculate the “Shape_Area” field in the benthic data to have the area be back 

into hectares. Instead of the “Create a new field” select the “Update Existing Field” and select the 

area field. 

 

Check-in 11: What are the top five protected areas for maximum protection of seagrass? 

 

30. Dive into the data specifically for Mango Island 

a. Option 1: "Select by Attribute" where NAME = Mango Island 

b. Option 2: Create a "Query Builder" where NAME = Mango Island 

c. Option 3: Select from the Attribute Table 

d. Export the data (either selected data or queried data) to the analysis folder 

 

If not sure about the values, can use the project_area_units to see 
current values and then apply the correct conversion to get from 
that unit to hectares [e.g., square meters to hectares is ($area / 
10000) → Output preview 2442751 / 10000 = ~245] 

https://docs.qgis.org/3.10/en/docs/user_manual/processing_algs/qgis/vectorselection.html#select-by-attribute
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Check-in 12: Rank the benthic classes from least to most area for Mango Island? How much 

coral/algae is protected? 

 

31. Clear the selection (  in the ribbon or use Ctrl+Shift+A) or delete the definition query 

from the dissolved joined protected benthic data with protected area names so that all the 

features are seen in the attribute table 

a. ***Note: Layer's attribute table should once again show 251 features 

32. Determine how many protected areas have benthic data by generating a table with the 

unique values. 

a. List Unique Values (Vector > Analysis Tool) 

i. Add the dissolved joined protected benthic data with protected area names 

layer 

ii. Target field = Name 

 

 
 

Check-in 13: How many protected areas have benthic classes? How does this compare to the 

number of marine and coastal protected areas across the central Tonga region?  ***Hint: Use the 

attribute table or right-click on the newly added table and mark the "Show Feature Count". 

 

Phase 4: Data analysis 

33. Calculate the benthic types across all the protected areas 

a. ***Hint: If get an error message again, rerun the same steps previously taken to 

troubleshoot the issue 

b. From the spatially joined dissolved data, run another dissolve but only using the 

benthic class [Benth_Comp] 

https://docs.qgis.org/3.10/en/docs/user_manual/processing_algs/qgis/vectoranalysis.html#list-unique-values
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i. ***Note: can use the original joined data, but will likely take longer since there 

are more features 

ii. ***Note: For geomorphic data, the field will be [Geo_Zone] 

c. Sum the total area of each benthic category 

i. ***Note: May need to recalculate the area field to have values in hectares 

d. ***Recommendation: Can delete any fields not related to the benthic category and area 

since they will populate as a default. 

e. Save data in the ecological folder (e.g., tonga_central_benthic_protected_moll) 

34. Prepare the central regional benthic class area to compare to the protected area data 

a. Dissolve the buffered Tonga central benthic data based on the benthic class 

b. Recalculate the area to make sure they are in hectares 

i. ***Note: As mentioned in the beginning of the tutorial, the central benthic 

data from the geodatabase are in square meters. Since the protected area data 

were calculated in hectares back in the previous step (33), to compare to the 

protected area data, these data need to be also in hectares. 

ii. Open the attribute table 

iii. Open "Field Calculator" 

1. Click on the "Field Calculator" icon in the ribbon 

2. Switch mark from "Create a new field" to "Update existing field" 

3. In drop down, select the area field 

4. If units are already in hectares, use $area 

5. If units are in square meters, convert the area to hectares in the 

software's properties 

6. ***Alternative: mathematically convert the area (1 ha = 10,000 m2) 

a. Add the area field from "Fields and Values" section under the 

search bar 

b. Click on "/" 

c. Click into the expression box and type "10000" 

d. ***Alternative: type "Shape_Area / 10000" into the expression 

box 
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Checkin-in 14: Which three benthic classes have greater than 10000 hectares in the central Tonga 

region? 

 

35. Join the dissolved protected area benthic data to the dissolved central region benthic class 

data 

a. Open the Processing toolbox (gear icon, Ctrl+Alt+T, or Processing > Processing 

Toolbox) 

i. Search for Join Attributes by field value 

1. Input layer: dissolved central region benthic class data 

2. Table field: Central Benthic 

3. Input layer 2: dissolved protected area benthic data 

4. Table field 2: Protected Benthic 

5. Join tyle: one-to-one 

ii. Save in the tonga_analysis folder (e.g., 

tonga_region_protected_benthic_join_moll) 

36. Create a new field to populate with percent each benthic class is protected 

a. Open Attribute Table 

b. Enable editing (press the pencil icon) 

c. Select "New Field" (attribute table icon with yellow/gold column) [Ctrl+w]) 

d. Name = "Percent" 

e. Type = Decimal number (real) 

 

***Note: Can type 
Shape_Area into 
expression box or 
find it in the "Fields 
and Values” section 

https://docs.qgis.org/3.10/en/docs/user_manual/processing_algs/qgis/vectorgeneral.html?highlight=join#join-attributes-by-field-value
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37. Rename fields to make them clearer 

a. Open layer’s properties 

b. Navigate to the “Fields” tab 

c. Turn on editing 

d. In the Name Field change the names 

i. Benthic and area fields for the region could become “Central” and “Central 

Ar” 

ii. Benthic and area fields for the protected areas could become “Protect” and 

“Protect Ar” 

38. Calculate the percent of each benthic habitat protected 

a. Open the "Field Calculator" for the "Percent" field 

b. Updating the existing field, divide the protected area by the central regional total 

benthic area and multiple by 100 
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Check-in 15: If Tonga was aiming to protect 20% of its coral reefs, has it achieved this goal in the 

central region using the coral/algae class? How about for seagrass? 

 

39. Calculating the contribution of each benthic class amongst the total of the all the protected 

areas requires a new field. 

a. Call the new field ProtPerc (Protected Percent) 

b. Similarly this will be a double field (as numbers will be entered to it) 

c. Calculate the sum of the benthic protection area column 

i. Turn on the editing in the attribute table 

ii. Open the expression dialog 

iii. From aggregates, select "Sum" 

iv. Choose the benthic protection area from "Fields and Values" 

v. Copy the value from the "Output preview" 

d. Calculate the percent of each benthic class from the protected total 

e. Verify that the percentages add up to 100 by calculating the sum again in the 

"ProtPerc" field 

 

Check-in 16: What is the total hectarage of the 7 benthic classes that are protected? 

 

 

 

 

https://docs.qgis.org/3.10/en/docs/user_manual/working_with_vector/expression.html#the-expression-string-builder
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Recap 

Upon reaching the end of this tutorial, you have successfully created and modified approximately 20 

data layers and are able to answer numerous questions that would be helpful for resource managers 

on benthic habitat and protected habitat. Aggregating and disaggregating the data in different ways 

can now answer: 

(1) How much of each benthic class is in the central Tongan region? 

(2) Which protected areas provide protection to benthic classes? 

(3) How much of each benthic class are in the protected areas? 

(4) What is the percentage of protected benthic classes within the central Tongan region? 

(5) What are the percentages of each benthic class in each protected area? 

 

Continuations 

This tutorial focused on the Allen Coral Atlas benthic class data. Geomorphic zone data, provided 

by the Allen Coral Atlas, could provide insights on propagation for the benthic habitats--natural or 

even artificial reseeding efforts. Thus, running these analyses again substituting the geomorphic zone 

data in place of the benthic habitat data would assist in identifying areas that meet keep thresholds to 

target for restoration and protection efforts. 

 

 
 

Total hectares 
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Allen Coral Atlas data can aid managers in adapting marine spatial planning to fulfill protection 

targets outlined by the Aichi Target 11 or another national target. You can investigate how much 

benthic habitat would be newly protected if protected areas were extended by a fixed distance, such 

as 1 kilometer. Alternatively, the benthic class areas that are not protected could be examined to see 

if a new protected area should be enacted or an existing one could be extended. 

 

Hint to answer these questions, the "Difference" tool produces all data that fall outside of an area of 

interest (e.g., protected areas / buffered protected areas) will be the most helpful way to complete 

those data. 

 

A common fifth phase of working with spatial data is constructing a map to share with key partners. 

These maps will be nice visualizations for others to see and understand the spatial relationships of 

benthic classes in the region and protected areas. Can create a map using the data generated and add 

map elements by selecting a new print layout. Check out this overview to see how QGIS can make a 

visualization for this project and any more you may pursue with the Allen Coral Atlas data! 

https://docs.qgis.org/3.10/en/docs/user_manual/processing_algs/qgis/vectoroverlay.html?highlight=difference#difference
https://docs.qgis.org/3.10/en/docs/user_manual/print_composer/overview_composer.html#:~:text=icon%20in%20the%20toolbar%20or,please%20follow%20the%20next%20instructions.&text=toolbar%20button%20and%20draw%20a,down%20the%20left%20mouse%20button.

